[Linux-HA] Reusable-Cluster-Components-glue: make error on 32-bit box

Nikita Michalko michalko.system at a-i-p.com
Fri Oct 22 06:57:48 MDT 2010


Hi all!

I know itt's annoying to do today something on the 32-bit server (SLES11/SP1), 
but I need it for testing purposes. After configuring the package  
Reusable-Cluster-Components-glue-1.0.6 with:
./autogen.sh && ./configure --enable-fatal-warnings=no --prefix=/usr 
--sysconfdir=/etc --sharedstatedir=/var/lib/heartbeat/com 
--localstatedir=/var
 it seems to be an error on make:
...
/bin/sh ../../libtool --tag=CC  --tag=CC   --mode=link gcc -std=gnu99 -g -O2 
-ggdb3 -O0  -fgnu89-inline -fstack-protector-all -Wall -Waggregate-return 
-Wbad-function-cast -Wcast-qual -Wcast-align -Wdeclaration-after-statement 
-Wendif-labels -Wfloat-equal -Wformat=2 -Wformat-security -Wformat-nonliteral 
-Winline -Wmissing-prototypes -Wmissing-declarations 
-Wmissing-format-attribute -Wnested-externs -Wno-long-long 
-Wno-strict-aliasing -Wpointer-arith -Wstrict-prototypes -Wwrite-strings 
-ansi -D_GNU_SOURCE -DANSI_ONLY -g -O2 -ggdb3 -O0  -fgnu89-inline 
-fstack-protector-all -Wall -Waggregate-return -Wbad-function-cast 
-Wcast-qual -Wcast-align -Wdeclaration-after-statement -Wendif-labels 
-Wfloat-equal -Wformat=2 -Wformat-security -Wformat-nonliteral -Winline 
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute 
-Wnested-externs -Wno-long-long -Wno-strict-aliasing -Wpointer-arith 
-Wstrict-prototypes -Wwrite-strings -ansi -D_GNU_SOURCE -DANSI_ONLY 
-version-info 2:0:0  -o libpils.la -rpath /usr/lib 
pils.lo ../../replace/libreplace.la  -lbz2 -lxml2 -lc -lrt -ldl  -lglib-2.0   
-lltdl
libtool: link: gcc -std=gnu99 -shared  .libs/pils.o  
-Wl,--whole-archive ../../replace/.libs/libreplace.a -Wl,--no-whole-archive  
-lbz2 /usr/lib/libxml2.so -lz -lm -lc -lrt -lglib-2.0 /usr/lib/libltdl.so 
-ldl    -Wl,-soname -Wl,libpils.so.2 -o .libs/libpils.so.2.0.0
/usr/lib/gcc/i586-suse-linux/4.3/../../../../i586-suse-linux/bin/ld: 
i386:x86-64 architecture of input file 
`../../replace/.libs/libreplace.a(NoSuchFunctionName.o)' is incompatible with 
i386 output
/usr/lib/gcc/i586-suse-linux/4.3/../../../../i586-suse-linux/bin/ld: final 
link failed: Invalid operation
collect2: ld returned 1 exit status
gmake[2]: *** [libpils.la] Fehler 1
gmake[2]: Leaving directory 
`/root/neueRPMs/ha/303/sourc/Reusable-Cluster-Components-glue-1.0.6/lib/pils'
gmake[1]: *** [all-recursive] Fehler 1
gmake[1]: Leaving directory 
`/root/neueRPMs/ha/303/sourc/Reusable-Cluster-Components-glue-1.0.6/lib'
make: *** [all-recursive] Fehler 1

Configuring  with --build=x86 didn't help

Many thanks in advance for the reply!
...
 
Nikita Michalko 



More information about the Linux-HA mailing list