[Linux-HA] Error compiling Heartbeat

Dejan Muhamedagic dejanmm at fastmail.fm
Fri Jul 17 02:21:18 MDT 2009


Hi,

On Wed, Jul 15, 2009 at 04:57:58PM +0200, Klaus Jagemann wrote:
> Hello List,
> 
> I need to set up a heartbeat cluster on RH4 ppc running on IBM iSeries
> LPAR. As there are no precompiled packages, I have to compile everything
> myself from source which fails due to incompatible libc.so/libc.a (see
> attached config.log). Did investigation it seems to me that compilation
> of heartbeat needs at least gcc version 4.1.3. while on our system the

Why?

> most recent available version is gcc4-4.1.2-44.EL4 (found on
> ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/)
> Could anyone shed some light into this issue to prevent me from running
> in the wrong direction? :)
> 
> Heartbeat-2.99.2-6.28.src.rpm
> (http://hg.linux-ha.org/dev/archive/tip.tar.bz2)
> Kernel 2.6.9-34.EL
> 
> Config.log (attached)

Something seems to be wrong with your compiler or libraries:

/usr/bin/ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
configure:2623: $? = 1

Thanks,

Dejan


> Cheers
> 
> Klaus


> _______________________________________________
> Linux-HA mailing list
> Linux-HA at lists.linux-ha.org
> http://lists.linux-ha.org/mailman/listinfo/linux-ha
> See also: http://linux-ha.org/ReportingProblems



More information about the Linux-HA mailing list