[Linux-HA] target-role does not exist with crm_resource

Gawith gawith at gmx.de
Thu Jul 9 05:40:22 MDT 2009


Hi,

yes, the problem disappeared in 1.0.4....
(Unfortunately, the excessive logging of pingd keeps me from using 1.0.4)

Regards.

Michael Schwartzkopff schrieb:
> Am Donnerstag, 9. Juli 2009 12:38:23 schrieb Dejan Muhamedagic:
>> Hi,
>>
>> On Wed, Jul 08, 2009 at 01:50:53PM +0200, Steinhauer Juergen wrote:
>>> Hi guys!
>>>
>>> I've experienced for several times, that I'm not able to query the
>>> resource status with crm_resource:
>>>
>>> crm_resource -r app -g target-role --meta
>>> Error performing operation: The object/attribute does not exist
>>>
>>> But the meta-attribute is there...
>>>
>>> <primitive class="ocf" id="app" provider="me" type="myapp">
>>>   <meta_attributes id="app-meta_attributes">
>>>     <nvpair id="app-meta_attributes-target-role" name="target-role"
>>> value="started"/>
>>>     <nvpair id="app-meta_attributes-migration-threshold"
>>> name="migration-threshold" value="1"/>
>>>   </meta_attributes>
>>> </primitive>
>>>
>>> It worked with pacemaker 0.6 (without the "--meta") and works sometimes
>>> with pacemaker 1.0.3.
>>>
>>> Am I doing something wrong? Is this way to query the app's status not
>>> supported anymore?
>> I can't reproduce this with 1.0.4. Which version do you run? Can
>> you also post the whole CIB?
>>
>> Thanks,
>>
>> Dejan
> 
> Strange enough, the problem disappeared here.
> 



More information about the Linux-HA mailing list