[Linux-HA] socket of lrmd

Junko IKEDA ikedaj at intellilink.co.jp
Thu Jul 2 01:09:16 MDT 2009


Hi,

When I run LVM RA with Heartbeat 2.1.4,
I could see the following message.

lrmd[14994]: 2009/07/02_15:29:20 info: RA output: (lvm:monitor:stderr) File descriptor 3 (socket:[46374]) leaked on vgck invocation. Parent PID 15446: /bin/sh

It seems that some LVM commands (vgdisplay or vgck) try to close the file descriptor which lrmd opened.
lsof command showed that lrmd had socket like this;

# lsof | grep lrmd | grep socket
lrmd      14994    nobody    3u     unix 0xffff81011b05f740               46374 socket

(for more details, see the attached hb_report and lsof.txt)

lvm commands tried to close this socket and failed. :(
What is this socket for?
For the communication with othre processes like crmd or ha_logd?

This problem depends on the specification of lvm,
but I just want to confirm whether the above log message could have an impact on the cluster behavior or not. 

This list might be the same issue.
http://www.gossamer-threads.com/lists/linuxha/users/49687

Thanks,
Junko
-------------- next part --------------
A non-text attachment was scrubbed...
Name: LVM.tar.gz
Type: application/x-gzip
Size: 48037 bytes
Desc: not available
URL: <http://lists.linux-ha.org/pipermail/linux-ha/attachments/20090702/0bd0d097/attachment.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: lsof.txt
URL: <http://lists.linux-ha.org/pipermail/linux-ha/attachments/20090702/0bd0d097/attachment.txt>


More information about the Linux-HA mailing list