[Linux-HA] Heartbeat took 20 min. to stop

Jose Jerez tale.toul at gmail.com
Fri Sep 21 04:56:01 MDT 2007


 Hello,

Today I had a problem stopping  heartbeat that I thought had been
solved in one of the latest releases:

First I set one node in standby mode with:

      #crm_standby -U justiciamacjh3 -v on

Then I stop heartbeat:

      #/etc/init.d/heartbeat stop

And it takes 20 minutes to stop, in the log file (attached) I see:

ERROR: crm_timer_popped: Shutdown Escalation (I_STOP) just popped!
 ERROR: do_log: [[FSA]] Input I_STOP from crm_timer_popped() received
in state (S_TERMINATE)
 info: verify_stopped: Checking for active resources before exit
 ERROR: verify_stopped: 1 pending LRM operations at shutdown
 ERROR: ghash_print_pending: Pending action: IP_db1:137
 ERROR: do_exit: Performing A_EXIT_1 - forcefully exiting the CRMd

I had found this problem in a 2.0.7 but I thought it had been solved by now.

System is SLES9 SP3 with heartbeat 2.1.2 compiled from source.

Regards.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ha-log
Type: application/octet-stream
Size: 77729 bytes
Desc: not available
URL: <http://lists.linux-ha.org/pipermail/linux-ha/attachments/20070921/c61035fa/attachment.obj>


More information about the Linux-HA mailing list