[Linux-HA] LZO requirement in interim RPMs

Dejan Muhamedagic dejanmm at fastmail.fm
Thu Oct 11 03:04:03 MDT 2007


Hi,

On Thu, Oct 11, 2007 at 02:37:05AM -0400, Carson Gaspar wrote:
> Andrew Beekhof wrote:
> 
> >all i know is that installing zlib failed when i removed the lzo dependancy
> >(the build service installs a minimal system from scratch for every 
> >compile)
> 
> Then either your package is broken (has a missing dependency) or the 
> build service is broken (doesn't check multi-level dependencies). Yuck. 
> I'll just keep hacking it out.

What I see in the spec file is this:

%if 0%{?suse_version} == 1000
BuildRequires: lzo
%endif

That's a relatively recent addition:

changeset:   11205:d9b854a6c9c9
user:        Alan Robertson <alanr at unix.sh>
date:        Fri Aug 03 21:32:01 2007 -0600
summary:     More specfile upgrades

So, it shouldn't apply to redhat/centos.

Thanks,

Dejan

> -- 
> Carson
> _______________________________________________
> Linux-HA mailing list
> Linux-HA at lists.linux-ha.org
> http://lists.linux-ha.org/mailman/listinfo/linux-ha
> See also: http://linux-ha.org/ReportingProblems



More information about the Linux-HA mailing list