[Linux-HA] Trouble in installing heartbeat.

Manilal K M libregeek at gmail.com
Fri Feb 3 06:16:58 MST 2006


On 03/02/06, Rui Vilao <rui.vilao at rocketmail.com> wrote:
> Greetings,
>
> I am trying to install the last heartbeat stable version (2.0.2) on two RHEL
> 4.0 (xb86) boxes.
>
> The architecture is:
>
> Linux rac1.test.com 2.6.9-11.ELsmp #1 SMP Fri May 20 18:26:27 EDT 2005 i686
> i686 i386 GNU/Linux
>
> When I try to install, I get:
>
> # rpm -ivh heartbeat-2.0.2-1.i386.rpm \
>  heartbeat-pils-2.0.2-1.i386.rpm \
>  heartbeat-stonith-2.0.2-1.i386.rpm
> error: Failed dependencies:
>         libcurl.so.2 is needed by heartbeat-stonith-2.0.2-1.i386
>
> libcurl.so.2 does not exist but libcurl.so.3 does. Curl is installed:
>
> # rpm -qa |grep curl
> curl-7.12.1-5.rhel4
> curl-devel-7.12.1-5.rhel4
>
> How can I solve this problem?
>
> Any help/suggestion is highly appreciated.
>

I too have this problem and solved it. I simply grabbed the SRPM from
the linux-ha website and rebuild the RPM.
# rpm -ivh heartbeat-x.x.x.src.rpm
# rpmbuild -ba /usr/src/redhat/SPECS/heartbeat.spec

and used the resultant RPMS.

regards
manilal



More information about the Linux-HA mailing list