[Linux-HA] CVS Script installation fails

David Qualls david.w.qualls at gmail.com
Tue Oct 25 01:05:19 MDT 2005


That's just it, it was there, but it was an apt-get install of it. I
reinstalled fc-4 ran CVS_getws.sh and it ran all the way thru and compiled.

-----Original Message-----
From: linux-ha-bounces at lists.linux-ha.org
[mailto:linux-ha-bounces at lists.linux-ha.org] On Behalf Of Alan Robertson
Sent: Monday, October 24, 2005 7:57 PM
To: General Linux-HA mailing list
Subject: Re: [Linux-HA] CVS Script installation fails

David Qualls wrote:
> CVS_getws.sh from the linux-ha downloads page
> 
> 
>  
> On 10/24/05, *Alan Robertson* <alanr at unix.sh <mailto:alanr at unix.sh>>
wrote:
> 
>     David Qualls wrote:
>      > When running the cvs script, I get the following errors?
>      >
>      > Any advice?
>      >
>      > gmake[2]: Entering directory
>     `/tmp/tmp.MrC17164/linux-ha/membership/ccm'
>      > gmake[2]: Leaving directory
>     `/tmp/tmp.MrC17164/linux-ha/membership/ccm'
>      > gmake[1]: Leaving directory `/tmp/tmp.MrC17164/linux-ha/membership'
>      > gmake[1]: Entering directory `/tmp/tmp.MrC17164/linux-ha/telecom'
>      > list='apphbd recoverymgrd'; for subdir in $list; do \
>      >   if test "$subdir" = .; then :; else \
>      >     test -d "/tmp/tmp.MrC17164/linux-ha/heartbeat-
>     2.0.3/telecom/$subdir" \
>      >     || mkdir -p --
>      > "/tmp/tmp.MrC17164/linux-ha/heartbeat-2.0.3/telecom/$subdir" \
>      >     || exit 1; \
>      >     distdir=`CDPATH="${ZSH_VERSION+.}:" && cd
>      > /tmp/tmp.MrC17164/linux-ha/heartbeat-2.0.3/telecom && pwd`; \
>      >     top_distdir=`CDPATH="${ZSH_VERSION+.}:" && cd
>      > /tmp/tmp.MrC17164/linux-ha/heartbeat-2.0.3 && pwd`; \
>      >     (cd $subdir && \
>      >       gmake   \
>      >         top_distdir="$top_distdir" \
>      >         distdir="$distdir/$subdir" \
>      >         distdir) \
>      >       || exit 1; \
>      >   fi; \
>      > done
>      > gmake[2]: Entering directory
>     `/tmp/tmp.MrC17164/linux-ha/telecom/apphbd'
>      > gmake[2]: Leaving directory
>     `/tmp/tmp.MrC17164/linux-ha/telecom/apphbd'
>      > gmake[2]: Entering directory
>      > `/tmp/tmp.MrC17164/linux-ha/telecom/recoverymgrd'
>      > yacc  -d conf_yacc.y
>      > gmake[2]: yacc: Command not found
>      > gmake[2]: *** [conf_yacc.c] Error 127
>      > gmake[2]: Leaving directory
>      > `/tmp/tmp.MrC17164/linux-ha/telecom/recoverymgrd'
>      > gmake[1]: *** [distdir] Error 1
>      > gmake[1]: Leaving directory `/tmp/tmp.MrC17164/linux-ha/telecom'
>      > make: *** [distdir] Error 1
> 
>     What script is "the CVS script"?  [There are dozens of scripts in
CVS].
> 
>     It looks like you're running gmake.  I don't think gmake is a script,
>     and I don't think it's in our CVS.  Perhaps being a little more
specific
>     might be helpful.
> 
> 
>     As always...
>     ----------->
>      > See also: http://linux-ha.org/ReportingProblems

OK

As was noted by someone earlier, you need to have the usual set of 
compiler tools including yacc/eyacc or bison.  I'm a little surprised 
you didn't get a complaint earlier (from configure) about not having a 
copy of yacc in your PATH.

-- 
     Alan Robertson <alanr at unix.sh>

"Openness is the foundation and preservative of friendship...  Let me 
claim from you at all times your undisguised opinions." - William 
Wilberforce
_______________________________________________
Linux-HA mailing list
Linux-HA at lists.linux-ha.org
http://lists.linux-ha.org/mailman/listinfo/linux-ha
See also: http://linux-ha.org/ReportingProblems




More information about the Linux-HA mailing list