[Linux-HA] Problem building 2.0.2 with make install

Steve Iribarne steve.iribarne at dilithiumnetworks.com
Thu Oct 20 09:38:51 MDT 2005



-> -----Original Message-----
-> From: linux-ha-bounces at lists.linux-ha.org [mailto:linux-ha-
-> bounces at lists.linux-ha.org] On Behalf Of Horms
-> Sent: Thursday, October 20, 2005 8:35 AM
-> To: General Linux-HA mailing list
-> Subject: Re: [Linux-HA] Problem building 2.0.2 with make install
-> 
-> On Thu, Oct 20, 2005 at 08:17:57AM -0700, Steve Iribarne wrote:
-> >
-> >
-> > -> -----Original Message-----
-> > -> From: linux-ha-bounces at lists.linux-ha.org [mailto:linux-ha-
-> > -> bounces at lists.linux-ha.org] On Behalf Of Horms
-> > -> Sent: Thursday, October 20, 2005 8:04 AM
-> > -> To: General Linux-HA mailing list
-> > -> Subject: Re: [Linux-HA] Problem building 2.0.2 with make install
-> > ->
-> > -> On Thu, Oct 20, 2005 at 07:58:13AM -0700, Steve Iribarne wrote:
-> > -> > <...snip...>
-> > -> > -> >
-> > -> > -> > Yes, the build was changed and as fall out libltdl isn't
-> > included
-> > -> > -> > in the tarball any more. This is probably causing your
-> > problem.
-> > -> > -> >
-> > -> > -> > Please install libltdl on your system, and it should be
used
-> > -> > -> > instead of the non-existent libltdl/ directory.
-> > -> > -> >
-> > -> > -> > This breakage was not done by my hand, don't kill the
-> > messanger :)
-> > -> > -> >
-> > -> > -> > I have an idea to make ./configure fail with some
sensible
-> > -> message,
-> > -> > -> like
-> > -> > -> > "go and install libltdl", if it is going to use libltdl/
and
-> > it
-> > -> > doesn't
-> > -> > -> > exist. Can interested parties comment?
-> > -> > -> >
-> > -> >
-> > -> > I can comment.. Just as a consumer of heartbeat.  It's ok
remove
-> > -> > dependencies in heartbeat, but make it obvious that you are
doing
-> > it.
-> > -> I
-> > -> > read the README and the INSTALL and it didn't say anything
about
-> > it.
-> > -> > Then I spent over an hour trying to find out what I did wrong
-> > because I
-> > -> > don't want to ask stupid questions on the mailing list.  ( I
do
-> > that
-> > -> > enough already!  :)
-> > -> >
-> > -> > I think there are two issues:
-> > -> >
-> > -> > 1.  There is no libltdl which I will install in my build
world.
-> > -> > 2.  I can't find the mkinstalldirs at the root level.
-> > -> >
-> > -> > To get around this yesterday, I just copied them from my 2.0
-> world.
-> > I
-> > -> > still don't know what happened to mkinstalldirs..
-> > ->
-> > -> Thanks, I'm glad that I'm not the only person
-> > -> who finds this situation annoying.
-> > ->
-> >
-> > Am I right about the mkinstalldirs?  Did that go away as well?
What do
-> > I need to do to get 2.0.2 "out of the box" compiling?
-> 
-> I'm not entirely sure about that bit, though I strongly suspect it
-> is related.
-> 
-> If you have a system that you can't install libltdl on, then
-> you are in a bit of a bind. A work around would be to find a system
-> that does have libltdl, on that system run:
-> 

No I can actually install libltdl on my system, albeit, I'll have to put
it in another location so that will be a bit of a challenge telling hb
where it is.

-> ./ConfigureMe --enable-bundled-ltdl
-> make dist
-> 
-> This should produce a tarball that includes the libltdl/ directory
-> and you could use that on the other system.
-> 
-> I haven't actually tested this, so no guarantees.
-> 

Thanks Horms for you help.





More information about the Linux-HA mailing list