[Linux-HA] Problem building 2.0.2 with make install

Horms horms at verge.net.au
Wed Oct 19 21:48:08 MDT 2005


On Wed, Oct 19, 2005 at 01:13:55PM -0700, Steve Iribarne wrote:
> Hiho.  
> 
>  
> 
> So I am running into an issue with 2.0 heartbeat.  So I figured, ok,
> I'll get up-to-date with the 2.0.2 sources.
> 
>  
> 
> So I downloaded the 2.0.2 sources.
> 
> Run ./ConfigureMe configure
> 
> make all
> 
> make DESTDIR=<full path to my install dir> install
> 
>  
> 
> I get the error:
> 
>  
> 
> Making install in libltdl
> 
> gmake[1]: Entering directory
> `/vobs/DTGngLinux/heartbeat-2.0.2/heartbeat-2.0.2/libltdl'
> 
> gmake[2]: Entering directory
> `/vobs/DTGngLinux/heartbeat-2.0.2/heartbeat-2.0.2/libltdl'
> 
> /bin/sh ./../mkinstalldirs
> /vobs/DTGngLinux/heartbeat-2.0.2/heartbeat-2.0.2/_install/usr/local/lib
> 
> ./../mkinstalldirs: ./../mkinstalldirs: No such file or directory
> 
> gmake[2]: *** [install-libLTLIBRARIES] Error 127
> 
> g
> 
>  
> 
> ideas?  

Yes, the build was changed and as fall out libltdl isn't included
in the tarball any more. This is probably causing your problem.

Please install libltdl on your system, and it should be used
instead of the non-existent libltdl/ directory.

This breakage was not done by my hand, don't kill the messanger :)

I have an idea to make ./configure fail with some sensible message, like
"go and install libltdl", if it is going to use libltdl/ and it doesn't
exist. Can interested parties comment?

-- 
Horms



More information about the Linux-HA mailing list