[Linux-HA] External stonith plugin for V2.0.2

Etienne van Tonder evt at infoware.com.au
Sun Oct 9 02:27:37 MDT 2005


I am totally confused, I'm hoping someone can help me.

I've installed the latest version of heartbeat in the hope of using the
external stonith module to shutdown an apc-smart ups that I'm using with a
USB cable. I can't use the serial interface as I only have one serial port
and it's being used for something else, apart from that I have tried stonith
with the serial port and I keep getting errors.

My plan was to use the external plugin to run a script that would call
apcupsd to shutdown the ups. I've written and tested the script and it works
as expected. I've read the README.external in the CVS and it does not seem
to apply to the latest version. When I do a stonith -h it no longer displays
external as an option, only external/ssh and external/riloe, there is no
external script in the external directory anymore (there use to be one in
V1.99).

>From the changelog it says  "fully supports scripting interface" so it seems
I have to write my own external plugin script??

I tried testing the external options using stonith from the command line but
I keep getting:

stonith: external ssh device not accessible

Can anyone please explain to me how this is all meant to work.

One other question does heartbeat depend on the return code from this script
to determine if the ups/machine has been shutdown or is this done via the
heartbeat (via eth1/tty), ie no heartbeat means ups shutdown worked??

Regards,

Etienne.




More information about the Linux-HA mailing list