[Linux-HA] A problem with a "simple" configuration

Or Goshen oberonc at gmail.com
Mon Jul 11 06:25:04 MDT 2005


Hello

First I'll give you some background :
heartbeat 1.99.5
2 machines each has 2 ports (eth0, eth1),
machine one (M1): eth0 = 192.168.2.241, eth1 = 10.0.0.2
machine two (M2): eth0 = 192.168.2.242, eth1 = 10.0.0.3
failover ip = 192.168.2.240

eth1 on both machines is connected thru a single crossed over network cable.
and each is capable of pinging the other.

there is a stable machine whose ip is X.X.X.X .

ha.cf (same on both machines) :
####################### Begin
logfacility daemon                           # Log to syslog as
facility "daemon"
node lbtest-master lbtest-slave              # List our cluster members
keepalive 1                                  # Send one heartbeat each second
deadtime 10                                  # Declare nodes dead
after 10 seconds
bcast eth1                                   # Broadcast heartbeats on eth0
ping X.X.X.X                              # Ping our router to monitor
ethernet connectivity
auto_failback no                             # Don't fail back to paul
automatically
respawn hacluster /usr/lib/heartbeat/ipfail  # Failover on network failures
###################### End

haresources (same on both machines) :
###################### Begin
lbtest-master 192.168.2.240
###################### End

authkeys (same on both machines) :
###################### Begin
auth 1
1 crc
###################### End

After executing "/etc/init.d/heartbeat start" I have the following problems :
1. nothing related to heartbeat is written to /var/log/daemon.log
(syslog is configured correctly)
2. I cant see the failover ip when I execute "ifconfig"
3. when I execute "/etc/init.d/heartbeat start" it looks as if it gets
stuck (Ctrl+C releases it)

any information that will be helpful to solve this problem, just ask
and I'll provide.

Or



More information about the Linux-HA mailing list